The Forward Look Network
The Forward Look Network
Search | Statistics | User Listing Forums | Chat | eBay | Calendars | Albums | Skins | Language
You are logged in as a guest. ( logon | register )

57 Royal with 392 project
Jump to page : < ... 2 3 4 5 6 7 8 >
Now viewing page 8 [50 messages per page]
View previous thread :: View next thread
   Forward Look NON-Technical Discussions -> Members RidesMessage format
 
mikes2nd
Posted 2020-08-02 12:22 AM (#601582 - in reply to #539179)
Subject: Re: 57 Royal with 392 project


Expert

Posts: 4357
200020001001001002525
ran out of welding gas so i couldn't finish the darn driveshaft...... have to go find a solid rubber mat to make the gas tank drop a bit... I honestly could do an in tank pump... the problem is fitting it in the tank, as the top of the tank is covered. This pump should be fine for volume I think.

I do have a big pcv valve, no downdraft. I was thinking about putting an access port under the back seat to get to the gas pump heh. I will be painting any shiny bolts.
Top of the page Bottom of the page
mikes2nd
Posted 2020-08-10 2:07 PM (#601870 - in reply to #539179)
Subject: Re: 57 Royal with 392 project


Expert

Posts: 4357
200020001001001002525
this is taking way to darn long...

https://www.youtube.com/watch?v=6tRj3kvaIkM
Top of the page Bottom of the page
Powerflite
Posted 2020-08-10 3:04 PM (#601877 - in reply to #539179)
Subject: Re: 57 Royal with 392 project



Expert 5K+

Posts: 6999
50001000500100100100100252525
Location: So. California
What master cylinder did you end up with? The reservoir fittings are really tall on it, but I like it otherwise.
Top of the page Bottom of the page
mikes2nd
Posted 2020-08-10 6:31 PM (#601894 - in reply to #539179)
Subject: Re: 57 Royal with 392 project


Expert

Posts: 4357
200020001001001002525
its the 79-80 dodge Truck master its 1.125 bore

https://www.rockauto.com/en/moreinfo.php?pk=309581&jsn=3

https://www.cardone.com/product/10-1860-master-cylinder



Top of the page Bottom of the page
mikes2nd
Posted 2020-08-11 3:22 AM (#601913 - in reply to #539179)
Subject: Re: 57 Royal with 392 project


Expert

Posts: 4357
200020001001001002525
reservoir fittings are not seated inside yet
Top of the page Bottom of the page
jboymechanic
Posted 2020-08-11 11:00 AM (#601925 - in reply to #539179)
Subject: Re: 57 Royal with 392 project



Expert

Posts: 1996
1000500100100100100252525
Location: Muskego, WI
That is my MC of choice, all three of my Plymouths have it.
Top of the page Bottom of the page
mikes2nd
Posted 2020-08-14 10:55 PM (#602069 - in reply to #539179)
Subject: Re: 57 Royal with 392 project


Expert

Posts: 4357
200020001001001002525

Cool glad im in good company... Its pretty massive. Do you use a proportioning valve or just let er rip??? Your using disc/drums?

Starting to look almost like a running engine... The little s**t is killing me... Ordered a gas pedal boot... and I don't have a good steering column cover...

Farking annoying when im missing bolts or certain little parts... Had to order some linkage parts... uhg wait... I don't know i need them but hey... I ordered turquoise vinyl paint also... have to wait. Ill get the carb in, and start the heater core and box finally. Fully cleaned out and getting set for wiring the whole car.

Im going with 58 tail lights, the regal lancer front pieces also(the big brows) and Dual 58 head lights.

I tested my horns. I have two types(autolite and spartan(I went with the spartans, they work like new))... would someone explain why are there so MANY goddarn different horns on these cars? Theres like 50 parts nums



Edited by mikes2nd 2020-08-14 11:02 PM




(HemiCarb.jpg)



Attachments
----------------
Attachments HemiCarb.jpg (237KB - 62 downloads)
Top of the page Bottom of the page
mikes2nd
Posted 2020-08-15 10:37 PM (#602110 - in reply to #539179)
Subject: Re: 57 Royal with 392 project


Expert

Posts: 4357
200020001001001002525
getting wiring ready...

ez wire harness 20 circuit kit
gm headlight switch
led headlights(looking for similar to challenger yellow daytime running lights), turn signal is yellow inset lens... giving shoutout to new challenger..
GM electronic ignition
Electronic choke
Voltmeter(replacing)
Back up lights on rear license plate surround
4 stop lights(58 housings)
Clock
led dash lights?
under dash lights
Concerned about column mapping...
Original oil gauge
260 amp alternator
dual electric fans
mini high power starter
variable wiper motor
58 dual headlights with 57 dodge bumper






(2018-Dodge-Challenger-SRT-Hellcat-Widebody-Front-Detail.jpg)



Attachments
----------------
Attachments 2018-Dodge-Challenger-SRT-Hellcat-Widebody-Front-Detail.jpg (316KB - 58 downloads)
Top of the page Bottom of the page
mikes2nd
Posted 2020-08-17 2:52 AM (#602146 - in reply to #539179)
Subject: Re: 57 Royal with 392 project


Expert

Posts: 4357
200020001001001002525
https://youtu.be/7TX_Spx7xQI
Top of the page Bottom of the page
60 Imp
Posted 2020-08-17 7:46 AM (#602152 - in reply to #539179)
Subject: RE: 57 Royal with 392 project


2000100010010010010025
Location: North Australia
She's coming together Mike! looks awesome. This is going to be a neat car, I hope you change your stance, and drive the wheels off this thing. Steve.
Top of the page Bottom of the page
mikes2nd
Posted 2020-08-26 2:08 PM (#602598 - in reply to #539179)
Subject: Re: 57 Royal with 392 project


Expert

Posts: 4357
200020001001001002525
Brakes are complete and bled... just may need some fine tuning on the adjustable pedal rod, this thing will stop on a dime i bet, pedal feels great... going to summit today to get a tranny cooler.

finishing up hoses, hopefully putting the heater core and box in today... then clean the whole inside out for wiring starting thurs... finally...

I will start buffing some trim also...

https://youtu.be/W2oVo8OWijI

https://youtu.be/ZyRctJ-RSb8

https://youtu.be/F0oKpOgUEmI



Top of the page Bottom of the page
mikes2nd
Posted 2020-08-29 12:47 PM (#602703 - in reply to #539179)
Subject: Re: 57 Royal with 392 project


Expert

Posts: 4357
200020001001001002525
s**tty paint on the trunk edges... barely touched it...

replaced the trunk hinge....

https://www.youtube.com/watch?v=ZPdnHlIragU

Top of the page Bottom of the page
mikes2nd
Posted 2020-08-30 11:10 PM (#602742 - in reply to #539179)
Subject: Re: 57 Royal with 392 project


Expert

Posts: 4357
200020001001001002525
https://www.youtube.com/watch?v=k-tNRiTeaZg


Shifter cable is adjusted, gas pedal in, kick down adjusted
trying to get the trans cooler in. tons of crap done. Running some wiring now..
Top of the page Bottom of the page
mikes2nd
Posted 2020-08-31 12:00 AM (#602743 - in reply to #539179)
Subject: Re: 57 Royal with 392 project


Expert

Posts: 4357
200020001001001002525
going with Ron Francis ignition switch also.. have to map it into the bezel somehow...

https://www.ronfrancis.com/prodinfo.asp?number=IS%2D02



(IS-02-Md.jpg)



Attachments
----------------
Attachments IS-02-Md.jpg (92KB - 49 downloads)
Top of the page Bottom of the page
Powerflite
Posted 2020-08-31 12:46 AM (#602744 - in reply to #539179)
Subject: Re: 57 Royal with 392 project



Expert 5K+

Posts: 6999
50001000500100100100100252525
Location: So. California
Then you will have to have 2 keys for the switch and doors. Why not use a '56 switch or a '57 Plymouth or DeSoto switch instead?
Top of the page Bottom of the page
57burb
Posted 2020-08-31 10:35 AM (#602756 - in reply to #602743)
Subject: Re: 57 Royal with 392 project



Expert

Posts: 3799
20001000500100100252525
Location: DFW, TX
What is the advantage of that ignition switch? The factory one fits in the bezel.
Top of the page Bottom of the page
mikes2nd
Posted 2020-08-31 5:09 PM (#602767 - in reply to #539179)
Subject: Re: 57 Royal with 392 project


Expert

Posts: 4357
200020001001001002525
I have the 57 dodge switch, I guess I could use it, just ignore the other wires... i wanted to simplify it, but as long as i only use the circuits i need im good. ill have to check it.

I may have been thinking the headlight switch is the "fuse box" switch
Top of the page Bottom of the page
mikes2nd
Posted 2020-09-02 9:46 PM (#602864 - in reply to #539179)
Subject: Re: 57 Royal with 392 project


Expert

Posts: 4357
200020001001001002525
https://www.youtube.com/watch?v=_pVdsmWo3Bc

all this custom little s**t is crazy... getting close to wiring...
Top of the page Bottom of the page
Chrispy
Posted 2020-09-08 12:44 PM (#603023 - in reply to #539179)
Subject: Re: 57 Royal with 392 project



Extreme Veteran

Posts: 520
500
Location: Colorado Springs, Colorado
So how much hood clearance would you say you have with the HH intake and that AVS? i've been told the HH intake is too tall for these cars but i've never been told by how much. I have one i want to use in my firesweep because the stock intake is terrible.
Top of the page Bottom of the page
mikes2nd
Posted 2020-09-08 11:24 PM (#603045 - in reply to #539179)
Subject: Re: 57 Royal with 392 project


Expert

Posts: 4357
200020001001001002525
I have about an inch, it fit... I went to a spector low profile intake. I might adjust it a bit and paint it black.

I am thinking about cutting the tubes on each side back also.... not using the tubes of course.

https://www.youtube.com/watch?v=NB1_ZnBG4eI

https://www.youtube.com/watch?v=nATSHjWCCTY




(618YnfVhilL._AC_SL1500_.jpg)



Attachments
----------------
Attachments 618YnfVhilL._AC_SL1500_.jpg (38KB - 44 downloads)
Top of the page Bottom of the page
57burb
Posted 2020-09-10 11:56 AM (#603072 - in reply to #539179)
Subject: RE: 57 Royal with 392 project



Expert

Posts: 3799
20001000500100100252525
Location: DFW, TX
The headliner dye turned out really nice. Hope you can use it!

It is normal for paint materials to build up on edges of panels. It's a consequence of the material flowing out, and it is just something you have to watch out for. It's one of the reasons that high-end paint jobs get sanded between each coat, to flatten that area so you don't get a "bump" around panel edges after laying down several layers of primer/paint.

To preface this, I am just saying this as an observation watching your car come together contrasted with my own experience of building the Chrysler. It is interesting to see your use of aftermarket parts in your build, and the challenges they can sometimes cause. Obviously I did some custom / one-off stuff on my car, but believe it or not, I did try to refinish and reuse all the OEM parts and fasteners wherever possible. Partially because I wanted it "period correct-ish" but also because they were already there, so they were free! This comment was prompted by the aftermarket radiator, necessitating the aftermarket trans cooler, and the myriad small bits and pieces needed to get the systems working properly. I did have the same thought while you showed the brake light switch too, lol. You have done a good job of planning ahead and making sure all that is accounted for, so good on ya. The car is coming along very nicely, and just wanted you to know, someone does watch your vids.
Top of the page Bottom of the page
Chrispy
Posted 2020-09-13 8:38 PM (#603173 - in reply to #539179)
Subject: Re: 57 Royal with 392 project



Extreme Veteran

Posts: 520
500
Location: Colorado Springs, Colorado
1” eh? That’s... tight for engine movement... I thought about getting the carb pad milled down some, it will hurt intake performance some but it won’t be as bad as hitting, I don’t want to cut the hood.

Edited by Chrispy 2020-09-13 8:41 PM
Top of the page Bottom of the page
mikes2nd
Posted 2020-09-13 9:32 PM (#603175 - in reply to #539179)
Subject: Re: 57 Royal with 392 project


Expert

Posts: 4357
200020001001001002525
oh im not doing a hood scoop no way... Its actually the front edge that comes closest... so it would have to rock a ton...I just put the wiring harness in today... holy cr@p im spending half the time looking sh*t up...
Top of the page Bottom of the page
mikes2nd
Posted 2020-09-28 12:50 AM (#603679 - in reply to #539179)
Subject: Re: 57 Royal with 392 project


Expert

Posts: 4357
200020001001001002525
just about done wiring.. moving inside to the dash now... repainted the trunk...

Going to prime the engine again, and get hopefully test crank it over soon..

https://www.youtube.com/watch?v=rDlKyZKw7pE
Top of the page Bottom of the page
mikes2nd
Posted 2020-10-02 12:06 AM (#603867 - in reply to #539179)
Subject: Re: 57 Royal with 392 project


Expert

Posts: 4357
200020001001001002525
I actually turned the engine over with the starter, tested starter and it worked..... scary

https://www.youtube.com/watch?v=qqsZ8nxACYo


Top of the page Bottom of the page
Powerflite
Posted 2020-10-02 11:13 AM (#603886 - in reply to #539179)
Subject: Re: 57 Royal with 392 project



Expert 5K+

Posts: 6999
50001000500100100100100252525
Location: So. California
If you paint outside, I've had great results by painting under an easy up as long as there is no wind. It keeps any crap from falling into your paint and keeps the direct sunlight off of your parts.
Top of the page Bottom of the page
mikes2nd
Posted 2020-10-02 6:56 PM (#603913 - in reply to #539179)
Subject: Re: 57 Royal with 392 project


Expert

Posts: 4357
200020001001001002525

yeah ive never had that happen before... was like a tiny blob... should be okay now.  i think im done painting i hope i am.

 

 



Edited by mikes2nd 2020-10-02 6:58 PM
Top of the page Bottom of the page
mikes2nd
Posted 2020-10-07 11:41 PM (#604166 - in reply to #539179)
Subject: Re: 57 Royal with 392 project


Expert

Posts: 4357
200020001001001002525
wrap pics... putting exhaust in the car now.. had to order parts to finish wiring.. uhg





(wrap1.jpg)



(wrap2.jpg)



Attachments
----------------
Attachments wrap1.jpg (222KB - 28 downloads)
Attachments wrap2.jpg (220KB - 29 downloads)
Top of the page Bottom of the page
mikes2nd
Posted 2020-10-10 1:58 AM (#604267 - in reply to #539179)
Subject: Re: 57 Royal with 392 project


Expert

Posts: 4357
200020001001001002525
Engine harness is complete...

https://www.youtube.com/watch?v=_qbyytIvXvo


finishing up dash...

Top of the page Bottom of the page
mikes2nd
Posted 2020-10-23 2:29 PM (#604827 - in reply to #539179)
Subject: Re: 57 Royal with 392 project


Expert

Posts: 4357
200020001001001002525
Going to go for a test fire this weekend... Got hoses... open headers though Still waiting on pipes off header. Test my electric fuel pump for leaks maybe tonight... get gas and antifreeze in it...



https://www.youtube.com/watch?v=PlH3sMph2mA
Top of the page Bottom of the page
Powerflite
Posted 2020-10-23 3:18 PM (#604830 - in reply to #539179)
Subject: Re: 57 Royal with 392 project



Expert 5K+

Posts: 6999
50001000500100100100100252525
Location: So. California
I don't recommend doing that. Get your exhaust all connected with mufflers and then setup your motor for breaking in the cam. Otherwise you risk ruining your lobes by doing any unnecessary startups. The first startup is pretty critical and you don't want to do it more than once if you can help it. Correct me if you are running a roller, but I didn't think so. Right before I run it, I pull the distributor and leave the intake & valley cover off. Then run a drill on your oil pump. Once you see a good amount of oil flowing over your cam, turn the motor over with the starter for a good while, while still running the drill on the pump. This seems to do a great job of avoiding the initial grind. Then put it together and start it up to break in the cam.

Edited by Powerflite 2020-10-23 3:25 PM
Top of the page Bottom of the page
mikes2nd
Posted 2020-10-23 3:33 PM (#604831 - in reply to #539179)
Subject: Re: 57 Royal with 392 project


Expert

Posts: 4357
200020001001001002525

yeah i was thinking about that... not rollers.. It been 8 months probably since i prelubed the engine.. hmm, i have bumped the engine over a little.


and I have engine assembly oil on the bearings/cam... comp cam zinc oil in the car. these are new lifters on original cam...

I was thinking just seeing if she will fire for a couple a seconds...



Edited by mikes2nd 2020-10-23 3:37 PM
Top of the page Bottom of the page
57burb
Posted 2020-10-23 8:19 PM (#604837 - in reply to #539179)
Subject: RE: 57 Royal with 392 project



Expert

Posts: 3799
20001000500100100252525
Location: DFW, TX
Ha, man, your video reminds me of going over wiring diagrams until my eyes rolled back in my head.

You'll have a breakthrough when your first circuit is tested and works! Mine was the dome lights. Everything else will fall together quickly after that.

Wiring your own car is SO much work... but very satisfying once you're done. Keep at it, you're close!

Edited by 57burb 2020-10-23 8:21 PM




(20180303_115308.jpg)



(20180308_221627.jpg)



(20180318_223139.jpg)



(20180319_225456.jpg)



(20180331_173444.jpg)



Attachments
----------------
Attachments 20180303_115308.jpg (129KB - 21 downloads)
Attachments 20180308_221627.jpg (113KB - 19 downloads)
Attachments 20180318_223139.jpg (153KB - 20 downloads)
Attachments 20180319_225456.jpg (156KB - 20 downloads)
Attachments 20180331_173444.jpg (160KB - 20 downloads)
Top of the page Bottom of the page
mikes2nd
Posted 2020-11-02 11:51 PM (#605259 - in reply to #539179)
Subject: Re: 57 Royal with 392 project


Expert

Posts: 4357
200020001001001002525
wow in the trunk? Hmm that's a loty to move to the dash

I got my headers welded up, still have to finish up the exhaust. My exhaust is custom, i wasnt thrilled with the exhaust I recieved though. Minor glitch from classic exaust

I have to finish welding up exhaust, got the radiator hoses in.
Top of the page Bottom of the page
57burb
Posted 2020-11-04 1:19 PM (#605300 - in reply to #605259)
Subject: Re: 57 Royal with 392 project



Expert

Posts: 3799
20001000500100100252525
Location: DFW, TX
Yep, it wasn't any issue at all. I did use both rocker channels. They have plenty of room though, even with power windows and solenoids for the shaved door handles. It really keeps the engine bay and under dash area neat and tidy. It did make the trunk space somewhat smaller especially since I upholstered it.

When you get the exhaust wrapped up, let's see a video of it running!
Top of the page Bottom of the page
mikes2nd
Posted 2020-11-12 1:51 AM (#605558 - in reply to #539179)
Subject: Re: 57 Royal with 392 project


Expert

Posts: 4357
200020001001001002525
this exhaust is a pita... stupid things spiral around the darn torsion bars...





(exhaust1.jpg)



(exhaust2.jpg)



Attachments
----------------
Attachments exhaust1.jpg (235KB - 8 downloads)
Attachments exhaust2.jpg (227KB - 8 downloads)
Top of the page Bottom of the page
60 Imp
Posted 2020-11-12 6:36 AM (#605560 - in reply to #539179)
Subject: RE: 57 Royal with 392 project


2000100010010010010025
Location: North Australia
pipes look good except for the wrinkly curve around the bar. I thought they all go around the torsion bars? Did you do it in 2 inch Mike?Here is 300 C pic I found.



(exhaust 300.jpg)



Attachments
----------------
Attachments exhaust 300.jpg (51KB - 9 downloads)
Top of the page Bottom of the page
mikes2nd
Posted 2020-11-12 8:27 AM (#605562 - in reply to #539179)
Subject: Re: 57 Royal with 392 project


Expert

Posts: 4357
200020001001001002525
yeah those wrinkles are from the one bend and the weld. its all custom, the 392 trans makes things tougher also, the hemi is alot tighter

All two inch.
Top of the page Bottom of the page
mikes2nd
Posted 2020-11-21 6:19 PM (#605901 - in reply to #539179)
Subject: Re: 57 Royal with 392 project


Expert

Posts: 4357
200020001001001002525

Okay had a leak in the gas tank... never trust em... couple pin holes in the strap area... that set me back... Fixed it, put the tank back in it. 93 octane.. put 3 gallons in it, test fired the fuel pump.. its pretty quiet... got gas... tried starting... car wasn't in neutral

 

would not fire at first... had the wires one position off(after i got the timing light out, showed spark, i knew i had gas). I had been playing with the wires so many times I must have got it off a position..

So after messing it fired, sounds great... I have a leak at the water cross over... one freeze plug i had over tightened and the nut broke off...got to pull that and replace after i order a new one... AND the tranny puked trans fluid..

I have NO engine oil leaks which im very grateful for... rear main seal seems to be good, i was very careful about that one. I will drop the tranny pan if I have to and redo it. Ill order a new oil pan gasket, i may have over tightened. I think it was cork... real slight drop, couple drips per day.



Edited by mikes2nd 2020-11-21 6:20 PM
Top of the page Bottom of the page
mikes2nd
Posted 2020-11-22 7:56 AM (#605915 - in reply to #539179)
Subject: Re: 57 Royal with 392 project


Expert

Posts: 4357
200020001001001002525
https://www.youtube.com/watch?v=QPOnHTt051M

Top of the page Bottom of the page
mikes2nd
Posted 2020-11-22 6:44 PM (#605937 - in reply to #539179)
Subject: Re: 57 Royal with 392 project


Expert

Posts: 4357
200020001001001002525
how in the hell do you get the transmission breather little cap off the back? with the trans in the car? Its crimped on... i tried to wedge it a bit...

Top of the page Bottom of the page
58coupe
Posted 2020-11-23 11:32 AM (#605952 - in reply to #539179)
Subject: Re: 57 Royal with 392 project



Expert

Posts: 1490
1000100100100100252525
Location: Alaska
Why do you want to remove the breather cap? Is it leaking fluid there?
Top of the page Bottom of the page
mikes2nd
Posted 2020-11-23 11:13 PM (#605966 - in reply to #539179)
Subject: Re: 57 Royal with 392 project


Expert

Posts: 4357
200020001001001002525
it spit out oil from the transmission fill tube.. i heard it can do that, i might try some air and see if it comes out, the cap is lloose.

I wont put hard air on it, just some gentle pressure.

I got the freeze plug out, ill need to buy a new set. Kind of annoying. Those hot heads copper ones did work well, i must have over tightened the one and the nut broke off. I fixed the water filler leak and put some sealant on the water pump bolt.

That should fix the leaks, no oil leaks, just the water leaks...

Anyone else experience full oil pressure on startup? i have 80 psi. I do have a 20% more high flow oil pump(melling).

I am a little worried about the oil filter so i am going to get another one, i talked to hot heads about recommended filters.
Top of the page Bottom of the page
Powerflite
Posted 2020-11-24 12:36 AM (#605969 - in reply to #539179)
Subject: Re: 57 Royal with 392 project



Expert 5K+

Posts: 6999
50001000500100100100100252525
Location: So. California
Congratulations on getting the motor running! Just use the filter you have to do the cam break in. Change it to something else afterward. The o-ring freeze plugs with the T-bar work well, but can seep if the surface is pitted. But they will never pop out on you, which is what I like about them. The trans in my Fireflite did the same thing you are describing. I drove it around the block as it spewed out the tube. Stopped the car and shut it off. Then I was able to refill it without the air bubble problem. Not sure what the proper procedure is.
Top of the page Bottom of the page
mikes2nd
Posted 2020-11-24 2:12 AM (#605970 - in reply to #539179)
Subject: Re: 57 Royal with 392 project


Expert

Posts: 4357
200020001001001002525

thanks yeah i asked someone else they said it sometimes can do that when empty, ill see if it settles down. Something about it being in gear possibly? I started the car up in the air but I don't think the wheels spun. Maybe you need to get it into gear quick

Yeah ill yank that filter off quick once i get a 10-15 minute break in done, that oil pressure is at the back of the block so I guess that mean im getting good pressure where it needs to be. I have comp cams zinc oil in the car.

this thing seem stout... no fan, hot heads intake with the avs2 carb... very responsive also(as you can see). I have a small exhaust leak i need to address.

I didn't touch the carb... just started it

I spent a lot of time learning wiring.. its a joke once you spend the time to learn it once. I did a lot of customization though. That oil pressure safety switch alone was probably a day f'ing around with it. Its about prep and planning with these wiring kits, get it in the right place the first time, but in the end pretty simple. Get all the parts you need ahead of time... making changes to the wiring sucks... order from amazon... wait 2 days... order from amazon wait 2 days... order from amazon wait 2 days... i still have to "map' the dash now.



Edited by mikes2nd 2020-11-24 8:54 AM
Top of the page Bottom of the page
57burb
Posted 2020-11-24 12:02 PM (#605981 - in reply to #605937)
Subject: Re: 57 Royal with 392 project



Expert

Posts: 3799
20001000500100100252525
Location: DFW, TX
Congrats man! Sounds great! And that oil pressure is plenty stout. Is that cam already broken in?

You don't have to wait two days for electrical parts to come from Amazon, there's plenty of other stuff to do.

The transmission vent cap doesn't usually need to come off. I think it will pop off if you pry on it. If you really want, I have three iron TFs in my shop and I can take a look at them the next time I'm down there to see if there's a way to get it off without damaging the cap.

Dang, you cut the e-brake cables off that rear? Gonna be hard to make that functional again.
Top of the page Bottom of the page
Jump to page : < ... 2 3 4 5 6 7 8 >
Now viewing page 8 [50 messages per page]
Jump to forum :
Search this forum
Printer friendly version
E-mail a link to this thread



(Delete all cookies set by this site)