Re: [Chrysler300] 300 F- Mysterious Oil Pump Loses Prime
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Chrysler300] 300 F- Mysterious Oil Pump Loses Prime





They are made by purolator 

 

From: 20220210200n behalf of
Sent: Wednesday, November 28, 2018 9:22 AM
To: scooter465@xxxxxxx
Cc: mark love; Chrysler300
Subject: Re: [Chrysler300] 300 F- Mysterious Oil Pump Loses Prime
 
 

Seem to be made by mopar -literally - as different inside than all the others. And different motivation to do it well. Probably by a factory of Fiat now . But I do not know . You can get “the price” , off dealer by haggling . 

For similar reasons ,factory  engineering upgrades , I wanted a Mopar rebuilt transmission for 02 Jeep —about 150k Miles , it got unhappy. Rock auto was 900 Mopar 3 k . Confronted with that dealer cut price by about half, they must still make $.  In thinking about “ how cheap you can get it “ remember labor , your time invested , car down, and overall mental hassle if it bombs. Worth 600 to me on trans looked at that way. Doing it twice would be three times that plus extreme aggravation . No thanks, to each his own . It works perfectly. 
If oil filter were 50 more and saves one 10k new ram engine , I am in .. (It is not 50)  . Same as synthetic oil or silicone brake fluid . Different in a beater , yes. 
Good thing to bang around ... 
Sent from my iPhone not by choice 

On 28 Nov 2018, at 8:32 am, scooter465@xxxxxxx wrote:

I would like to know who actually
Makes Mopar filters. Any ideas IE
Wix, Fram.

Bob Haag


Sent from my iPhone

On Nov 28, 2018, at 7:19 AM, John Grady jkg@xxxxxxxxxxxxxxxxx [Chrysler300] <Chrysler300-noreply@xxxxxxxxxxxxxxx> wrote:

 

Problem with recommendations is they are anecdotal / hearsay unless you actually opened the filters . So “ had good luck with anything”  is exactly that. The thing I saw blew me away , it showed filters opened up and parts spread out , name brands . The real Mopar filter was so much better made,  it was really shocking and surprising to me . In reality —-!


! It is truly about the $ . If filter valve or straining material fails on a new hellcat they have to eat the cost of the new engine . So not them being kind to us.   It is $ thing.  Conversely if you are making dime a dozen oil filters for 10$—  it is all about making money on a throw away item in a China factory at a low price.  So now I know something new . And “For sure”  —not just hearsay or opinion . The article was in a Mopar / Marelli glossy parts magazine mailed to independent repair shops, maybe they were having problems . But the photos do not lie . The photos had maybe 10-15 arrows pointing to differences , and clearly explained . So I believe. And I  am a skeptic . But I do understand $ motive in this causing it to happen. I had used wix and Napa gold. Which might be good, but do not know for sure. Relegated to oil burner now. Bought all Mopar at dealer right away . Not a place to save 5$ . Thinking about it more , if oil pump hex drive looks good , not rounded off and no cracks at pickup pipe thread or attachment , almost has to be drain back function in filter did not work ?   It is like a little one way flapper in there . 
I would get a Mopar filter for sure ? But your call .. early engine 331 not screw on filter ? unless converted ( a good idea to do ) , this was about screw on filters . Hot Heads sells adapter for doing that . 

Sent from my iPhone not by choice 

On 27 Nov 2018, at 11:24 pm, mark love <marklove@xxxxxx> wrote:

Only comment so far to add is I’ve been using WIX filters ( also on my 331 and 354 and 440 Imperials) as recommended by my Mopar buds. If anyone has had bad issues with WIX, would be good to know. The pump was fine and the valve spring fine (no apparent wear or grooves).  Guess I’ll drive it for the rest of the week here in sunny 80 degree California and report anything else. Thanks for the responses. Puts my mind at ease. 

Sent from my iPhone

On Nov 27, 2018, at 5:17 PM, John Grady jkg@xxxxxxxxxxxxxxxxx [Chrysler300] <Chrysler300-noreply@xxxxxxxxxxxxxxx> wrote:

 

One known problem with B blocks of the era was stripping or breaking off of the oil pump drive hex where it goes into pump . The pump drive is more highly loaded with cold oil , and could be on verge of stripping out . Or hex in pump . I had a friend that lost two 426 max wedge brand new cars due to this . Both times while racing at high rpm . Some one like Miloden makes super pump drives and pumps . Sometimes Chinese junk gets into our parts places .. happened to me on slant six oil pump ,drive gear spun on shaft almost lost engine . Investigation =too loose for intended press fit .
Not saying for sure . I also understand oil filters have anti drain back valves , might have failed . Mopar filters are worth it . At dealer . Saw dissection of filters , some name brands are junk inside . Mopar has to be sure it works.. warrantee on engine .
Hope this helps ..
cracks at oil pickup pipe could also let air into suction side ..
let us know if you find anything definitive ?

Sent from my iPhone not by choice

> On 27 Nov 2018, at 11:51 am, mark love marklove@xxxxxx [Chrysler300] <Chrysler300-noreply@xxxxxxxxxxxxxxx> wrote:
>
> Had a unique issue and would appreciate any comments that might keep it from happening again. Drove my 300F for 10 days or so in October and put it away in the garage. Just connected the battery. Was running 50/50 91 non lead and /110 lead fuel. Car recently tuned and running beautifully. Came back to the garage and she fired up with some gently pedal work, but got noisy fast on the top of the motor. Looked down and no oil pressure. Turned it off. Waited, Turned it over. Same result. Turned it off. Took off the oil pump and everything looked fine (motor rebuilt by George Riel in ’04 but only 7,000 mi ago, engine oil is fresh and looks clear, changed in 5/18, is 10-30 conventional with ZDDP at 1600 ppm). Re-oiled the internals and put it back in. Started her up and presto, all is well. Would anyone opine on how the pump lost its prime, which is the only conclusion I could come to? Any ideas on how to keep it from happening again as the car will sit after this week for 5 months over the winter?
> Mark.
>
> ------------------------------------
> Posted by: mark love <marklove@xxxxxx>
> ------------------------------------
>
> To send a message to this group, send an email to:
> Chrysler300@xxxxxxxxxxxxxxxxxx
>
> To unsubscribe from this group, send an email to bob@xxxxxxxxxxxxx or
> go to https://groups.yahoo.com/neo/groups/all/manage/edit
>
> For list server instructions, go to http://www.chrysler300club.com/yahoolist/inst.htm
>
> For archives go to http://www.forwardlook.net/300-archive/search.htm#querylang
> ------------------------------------
>
> Yahoo Groups Links
>
>
>



__._,_.___

Posted by: DR CHALLENGER <drchallenger@xxxxxxxxxxx>


To send a message to this group, send an email to:
Chrysler300@xxxxxxxxxxxxxxx

To unsubscribe from this group, send an email to bob@xxxxxxxxxxxxx or
go to https://groups.yahoo.com/neo/groups/all/manage/edit

For list server instructions, go to http://www.chrysler300club.com/yahoolist/inst.htm

For archives go to http://www.forwardlook.net/300-archive/search.htm#querylang





__,_._,___


Home Back to the Home of the Forward Look Network Archive Sitemap


Copyright 2018 The Forward Look Network.  All rights reserved.

Opinions expressed in posts reflect the views of their respective authors.