Re: [Chrysler300] No Power Steering on My 58 D
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Chrysler300] No Power Steering on My 58 D





Hi Dave,
Center the steering wheel and jack up the car so the front wheels are off the ground. Start the car and see if it self steers to either side. The valve body seeds to be centered so it does not self steer to either side.
Don
 
Sent: Saturday, April 14, 2018 10:25 AM
Subject: [Chrysler300] No Power Steering on My 58 D
 
 

Hi Everyone.
Started My D after its winter lay up and had no power assistance for the steering at all. It was fine when parked last October but had not been run since.
The fluid in the pump looked slightly discoloured but not too bad I have removed the pump and cleaned it out and that seems ok, the power steering pipes were new when fitted in 2011 and are clean I have cleaned out the valve body on top of the steering box.
Now when started I have good assistance turning to the right but nothing turning to the left. Can anybody advise on what maybe causing this?
Regards Dave.



__._,_.___

Posted by: <dverity@xxxxxxxxxxx>


To send a message to this group, send an email to:
Chrysler300@xxxxxxxxxxxxxxx

To unsubscribe from this group, send an email to bob@xxxxxxxxxxxxx or
go to https://groups.yahoo.com/neo/groups/all/manage/edit

For list server instructions, go to http://www.chrysler300club.com/yahoolist/inst.htm

For archives go to http://www.forwardlook.net/300-archive/search.htm#querylang





__,_._,___


Home Back to the Home of the Forward Look Network Archive Sitemap


Copyright 2018 The Forward Look Network.  All rights reserved.

Opinions expressed in posts reflect the views of their respective authors.