Re: [Chrysler300] Later model (300K) ignition switch tumbler.
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Chrysler300] Later model (300K) ignition switch tumbler.

Hi Keith;
You may be working on the wrong end of the problem.
Might be just that the starter is not disengaging.
Could be the Solenoid is sticking and holding the drive gear and contact internally.
Unplug the signal wire (the wire from the Ing. switch) from the solenoid, and use a jump wire from the Battery to engage the starter. Remove the jumper and see if the starter stops. 
If it doesn't, the solenoid is the problem.
Let us know how it works out..

On Fri, Mar 9, 2018 at 8:26 PM, 'keith_a_lang@xxxxxxxxx' keith_A_Lang@xxxxxxxxx [Chrysler300] <Chrysler300-noreply@xxxxxxxxxxxxxxx> wrote:

Hey folks

My K doesn't disengage the starter via the ignition key so I'm trying to remove the ignition key assembly on my K. I thought this would be easy but is not because I'm missing somerhing. I thought I could just depress a little nub and the key assembly would come out. 

Unfortunately, it isn't coming out so any advice would be most appreciated.



Sent from my LG Phoenix 3, an AT&T 4G LTE smartphone

Ray Jones. Y'all come on down an see us. Ya hear?


Posted by: Ray Jones <1970hurst@xxxxxxxxx>

To send a message to this group, send an email to:

To unsubscribe from this group, send an email to bob@xxxxxxxxxxxxx or
go to

For list server instructions, go to

For archives go to

Visit Your Group
Yahoo! Groups
PrivacyUnsubscribeTerms of Use


Home Back to the Home of the Forward Look Network Archive Sitemap

Copyright 2018 The Forward Look Network.  All rights reserved.

Opinions expressed in posts reflect the views of their respective authors.